Color Correction in Source SDK 2010 (AS)

Discussion in 'Mapping Questions & Discussion' started by ForbiddenDonut, Mar 31, 2013.

  1. ForbiddenDonut

    aa ForbiddenDonut

    Messages:
    391
    Positive Ratings:
    338
    Bleh. So, this isn't about TF2 Mapping or the 2007 version of Hammer in general, but I'm stuck and thought I'd throw this out there to see if someone can help un-stump me.

    A few friends and I are putting together a full-conversion mod with the Alien Swarm base. We were trying to get color correction into the game, but we're having issues - it just won't show up.

    Here's the setup:

    After creating the color correction in the color correction tool editor by running the game with -tools -nop4, I saved the .vcc and the .raw to the 'sourcemods/mymod/scripts/colorcorrection' folder (this is the corresponding location to where Alien Swarm saves their cc files). The .raw file is named 'cc_cryo.raw'.

    The maps have a color_correction entity that has Lookup Falloff End Distance set to '-1' and the Lookup Table Filename set to 'scripts/colorcorrection/cc_cryo.raw'. The entity has the flags 'Master' and 'Client-Side Simulation' checked.

    I even tried adding in a fog_volume and setting the ColorCorrection Name to the name of the color_correction entity. Alas, we have not been able to get it to work.

    If there's something I'm missing or a step I skipped, please let me know. I'd love to get it functional.
     
  2. Burnout6010

    Burnout6010 L5: Dapper Member

    Messages:
    207
    Positive Ratings:
    23
    What I've always done in AS is using triggers to make the color_correction go on. Maybe the SDK maps in AS could help you see what I mean with triggers
     
  3. Egan

    aa Egan

    Messages:
    1,313
    Positive Ratings:
    1,491
    Does any other alien swarm map use colour correction? (If so just decompile the map and figure out the weird entity logic apparently going on).

    Maybe your .raw file is giving an error, try opening it in a photo editing program.

    Maybe try a logic_auto the enables the colour correction after the map starts, maybe alien swarm is weird like that.

    Though try step 1 first, cause that seems best.
     
  4. ForbiddenDonut

    aa ForbiddenDonut

    Messages:
    391
    Positive Ratings:
    338
    Thanks for the responses, guys.

    Turns out we had a shader that was conflicting with color correction's processing. We've since fixed the problem.