Clipping tool bugging out

Discussion in 'Mapping Questions & Discussion' started by Dain, Oct 6, 2014.

  1. Dain

    Dain L3: Member

    Messages:
    106
    Positive Ratings:
    40
    I'm trying to clip a cylinder to make a 1/8th slice. I clipped out the 1/4 piece just fine, but when I come to slice at the 45 degree angle through the centre, I can only clip on one side - I can't let the other side survive. Pressing shift-x cycles through either this:

    [​IMG]

    or this:

    [​IMG]

    Then I tried to outsmart it: I duplicated the cylinder then used vertex edit to smush all the righthand vertices together like so:

    [​IMG]

    but I am foiled again:

    [​IMG]

    This doesn't seem to be a problem with the VMF saving the vertices wrong: it happens on old solids and new ones I just made.

    I have no idea why Hammer is okay with the righthand pizza slice but not the lefthand one.

    pls help
     
  2. wareya

    wareya L7: Fancy Member

    Messages:
    493
    Positive Ratings:
    172
    If you try to clip on an existing offgrid vertex, it can make a microface where the clip intersects the vertex.
     
  3. Dain

    Dain L3: Member

    Messages:
    106
    Positive Ratings:
    40
    It's not offgrid, it's still on grid even on the 16-unit scale.
     
  4. Seba

    aa Seba DR. BIG FUCKER, PHD

    Messages:
    2,363
    Positive Ratings:
    2,365
    Manually make the brush?
     
  5. Izotope

    aa Izotope Never releases maps

    Messages:
    615
    Positive Ratings:
    573
    Try snapping all your vertices to the smallest grid size by selecting all vertices of that brush and pressing CTRL+B
    This will fix that issue:
    [​IMG]

    You might have that, so yeah doesn't hurt trying.