Checkerboards?

Discussion in 'Mapping Questions & Discussion' started by HQDefault, Dec 20, 2014.

  1. HQDefault

    HQDefault L12: Fabulous Member

    Messages:
    938
    Positive Ratings:
    266
    Every once in a while, when I have a texture on a surface, it will have a weird checkerboard pattern on it. What's the cause? How do I fix it? (No, not pink and black. This has nothing to do with missing textures or cubemaps)
     
  2. Egan

    aa Egan

    Messages:
    1,302
    Positive Ratings:
    1,478
    I'm not sure what it's caused by, although I have glimpsed some people in chat talking about it so someone probably knows, anyway here's a screencap that I have of it (probably?):

    [​IMG]
     
  3. HQDefault

    HQDefault L12: Fabulous Member

    Messages:
    938
    Positive Ratings:
    266
    Yes :) That's the one
     
  4. Crash

    aa Crash func_nerd

    Messages:
    3,074
    Positive Ratings:
    4,563
    Has something to do with the bump map layer, afaik. There's a ground texture that does the same thing.
     
  5. HQDefault

    HQDefault L12: Fabulous Member

    Messages:
    938
    Positive Ratings:
    266
    K... that's good to know... but how do I get it to stop?
    Or are those textures just doomed to be broken?
     
  6. Shogun

    Shogun L6: Sharp Member

    Messages:
    262
    Positive Ratings:
    228
    The ground texture Crash is talking about is completely broken, and whenever someone uses it someone else will always tell them it broken and not to use it. I wouldn't be surprised if this texture is broken too.
     
  7. Fr0Z3nR

    aa Fr0Z3nR Creator of blackholes & memes. Destroyer of forums

    Messages:
    6,391
    Positive Ratings:
    4,902
    Blend layer, not bump layer.
     
  8. henke37

    aa henke37

    Messages:
    1,836
    Positive Ratings:
    420
    The checkerboard is the source error texture, it is used when the correct texture failed to load, usually because it doesn't exist.

    Basically check the material for which textures it uses and verify that those exist.

    Also, verify your cache in steam to ensure that no files have gone corrupt.
     
  9. HQDefault

    HQDefault L12: Fabulous Member

    Messages:
    938
    Positive Ratings:
    266
    Ahem...

     
  10. henke37

    aa henke37

    Messages:
    1,836
    Positive Ratings:
    420
    It is the same texture, the pinkness just didn't end up visible because of reasons. Probably because the shader only checked one channel.
     
  11. Pocket

    aa Pocket func_croc

    Messages:
    4,489
    Positive Ratings:
    2,213
    Yep. Because one channel (green) is all black and the others are black and white. So the thing Egan posted could be a missing normal map, missing ssbump, or missing blendmap. I'm guessing normal map. Are you sure this is a stock texture and one designed for TF2? I can't tell from that screenshot what it's actually supposed to be.
     
  12. Egan

    aa Egan

    Messages:
    1,302
    Positive Ratings:
    1,478
    I replaced it in my vmf already, but it must be one of these from soho, if I recall correctly:

    [​IMG]
     
  13. Pocket

    aa Pocket func_croc

    Messages:
    4,489
    Positive Ratings:
    2,213
    I don't even know why those five textures are in Soho anyway; they all look exactly like stock textures that are in the concrete folder.