Cant save maps as .vmf, only as .map or .rmf

Discussion in 'Mapping Questions & Discussion' started by [INSERT USERNAME], Jul 12, 2017.

  1. [INSERT USERNAME]

    [INSERT USERNAME] L1: Registered

    Messages:
    6
    Positive Ratings:
    1
    I've started using hammer and have made multiple test maps but i cant compile them because i cant save them as a .vmf file, is there a way to run them without them being saved in this format, if not how do i fix this?
     
  2. 200

    200 L1: Registered

    Messages:
    47
    Positive Ratings:
    68
    Are you sure you are using the right Hammer version? Make sure it is [Steam Folder]\steamapps\common\Team Fortress 2\bin\hammer.exe, not the one that comes with Source SDK.
     
  3. [INSERT USERNAME]

    [INSERT USERNAME] L1: Registered

    Messages:
    6
    Positive Ratings:
    1
    Thanks for this Ill try checking it :D

    Now i have checked this, and this is what I've found, the Hammer I'm using, is in the correct folder:
    C:/Program Files (x86)> Steam> steamapps> common> Team Fortress 2> bin, and the Hammer version is just Hammer, no .exe at the end, although although the type of file it is, is an .exe. I'm on windows 10 (pretty shit) and I've looked around but cant find the proper .exe hammer, in any files.
     
    Last edited: Jul 13, 2017
  4. [Rx.] Christian Troy

    [Rx.] Christian Troy L4: Comfortable Member

    Messages:
    162
    Positive Ratings:
    43
    When you save the changes and/or a new map, are you choosing "Save" under the File tab or "Save as"?
     
  5. Lampenpam

    aa Lampenpam

    Messages:
    1,019
    Positive Ratings:
    337
    You might wanna display file type endings in your file browser. Click on "view" and then "display file endings" or something like that, my Windows is in german.

    [​IMG]

    This can be handy when you are using custom textures since they usually have two files named the same but with two different file types.
    Even if you don't enable it, it still says what kind of file it is on the right, but the ending is just closer in view and it's usefull in case you need to edit the file type ending.
     
    Last edited: Jul 13, 2017
  6. [INSERT USERNAME]

    [INSERT USERNAME] L1: Registered

    Messages:
    6
    Positive Ratings:
    1
    Thx Lampenpam, that actually helped, and as for Troy, i can save them as either but same thing, i can only save them as a .map or .rmf, anyone know how to solve this?
     
  7. 【EmNudge】

    【EmNudge】 L4: Comfortable Member

    Messages:
    180
    Positive Ratings:
    37
    If you're getting options you're probably using Save As..
    just use Ctrl + S to save. The first time it prompts you it will give .vmf as an option.

    Also, if you're still having problems, send a screenshot, it may help.
     
  8. Idolon

    aa Idolon the worst admin

    Messages:
    1,525
    Positive Ratings:
    4,334
    Go to Tools > Options and make sure Map Type is set to Half-Life 2 instead of Half-Life / TFC.

    [​IMG]
     
    • Agree Agree x 2
    • Thanks Thanks x 1
  9. [INSERT USERNAME]

    [INSERT USERNAME] L1: Registered

    Messages:
    6
    Positive Ratings:
    1
    Ok then, sure will Idolon, and thanks for the help. :D This has solved everything for me.