Can't Run Source Sdk

Discussion in 'Mapping Questions & Discussion' started by yohoat9, Jan 27, 2010.

  1. yohoat9

    yohoat9 L1: Registered

    Messages:
    4
    Positive Ratings:
    0
    So the other day I was making a map on hammer, and the next day it just stopped working... When I open it it says "No game configurations to run with" and when I click OK it doesn't let me click any other buttons, so no suggestions for pressing Reset Game Configurations or something is going to help, because I can't click them, any help?
     
  2. Beetle

    Beetle L9: Fashionable Member

    Messages:
    627
    Positive Ratings:
    141
    A couple of things could have happened.

    If you try to start the SDK before you have launched the game after installing/re-installing it, that will happen. So if you just recently reinstalled but haven't actually gone in game at least once there won't be a tf2 folder and therefore won't be any SDK configs for it.

    Stupid check, but make sure a tf2 folder exists. Maybe someone did a system restore on your computer to a point before it was installed.

    While typing this I forgot the other one I had in mind. Maybe I'll remember it.:facepalm:
     
    Last edited: Jan 27, 2010
  3. yohoat9

    yohoat9 L1: Registered

    Messages:
    4
    Positive Ratings:
    0
    but I was doing the map a day before, I checked and Have a tf2 folder, and I just want sdk back so much, and really try to remember that last one
     
  4. Nutomic

    Nutomic L11: Posh Member

    Messages:
    888
    Positive Ratings:
    177
    Have you tried starting tf2 before starting sdk and hammer?
     
  5. yohoat9

    yohoat9 L1: Registered

    Messages:
    4
    Positive Ratings:
    0
    yes, as I said before I was making a map previously... and the next day it didn't work... i have no idea why it happened
     
  6. Aki

    Aki L4: Comfortable Member

    Messages:
    155
    Positive Ratings:
    4
    Try rebooting your computer. Never know - and when I worked online tech support we found 9 out of 10 times a reboot would fix the issue. Don't know if you've tried that but worth mentioning.
     
  7. yohoat9

    yohoat9 L1: Registered

    Messages:
    4
    Positive Ratings:
    0
    This happened a few days ago, and just now I decided to post a thread, I have no idea why its happening and I can only thing of deleting STEAM and re-installing everything...
     
  8. Beetle

    Beetle L9: Fashionable Member

    Messages:
    627
    Positive Ratings:
    141
    Only thing left I can think of in Verifying Integrity for TF2 and the SDK by right clicking on each, going into the options, and clicking on the Verify button. It might not help, but it never hurts.