Can't launch map portalnum>numareaportals

Discussion in 'Mapping Questions & Discussion' started by takabuschik, Apr 4, 2014.

  1. takabuschik

    aa takabuschik

    Messages:
    660
    Positive Ratings:
    308
    [​IMG]
    Tried to launch map after a fast compile
    I have no idea. I only know that the map's optimisation is not so good (actually, there's no hint and areaportal optimisation, some odd shaped rooms and some huge open areas)
     
  2. DOMINATOR

    DOMINATOR L1: Registered

    Messages:
    11
    Positive Ratings:
    0
    most likely a leak. load the pointfile and look.

    post your compile log if its not a leak.

    edit TIP: when you load the pointfile - turn off everything but world geometry in your visgroups
     
    Last edited: Apr 4, 2014
  3. A Boojum Snark

    aa A Boojum Snark Toraipoddodezain Mazahabado

    Messages:
    4,769
    Positive Ratings:
    5,527
    If you really didn't add areaportals I'm not sure... I've only ever known it to be associated with that.

    If it isn't an areaportal leak, this can also happen if you have areaportals too far apart that are merged. Any area portals that share the same plane on both sides will be merged, regardless of distance. This will most commonly be an issue with mirrored maps (rather than rotated symmetry) but can also happen when just careless or unaware.
    When merged, they become one areaportal that encompasses the entire area between the two, and in cases like this that is such an enormous area that is overflows a limit and throws that error.

    You can usually fix this easily by shrinking the thickness of one or both areaportals that are being merged. As an example, here is a pic showing the spawn door areaportals for Egg War. It is mirrored so the doors are on exactly the same plane, but since they are in a 16 unit thick wall, I just made them 8 units thick and set one to the inside and one to the outside.

    [​IMG]
     
  4. wareya

    wareya L7: Fancy Member

    Messages:
    493
    Positive Ratings:
    172
    So THAT'S why decompiled gorge has a bunch of weird areaportals!
     
  5. takabuschik

    aa takabuschik

    Messages:
    660
    Positive Ratings:
    308
    I think I solved the issue...
    I had some areaportal leak (apparently I had areaportals, I just forgot about them) and it didn't create any pointfile for some reason

    Here's the full story, you don't have to read if you don't care
    -My whole map was misaligned
    -selected the whole map, pressed ctrl+shift+B (align to grid)
    -stuff aligned to grid, but not all of it aligned together with other stuff around it
    -I didn't notice it, but some of the areaportals misaligned, some complex shapes made holes that caused areaportal leaks
    -got this error
    -compilation didn't create a pointfile, that's why I assumed there's no leak (and created this thread)
    -found out there is a leak
    -sat down for a few hours, compiling only VBSP, loading pointfiles, and fixing hundreds of strange leaks which I never thought could exist
     
  6. sclera

    sclera L1: Registered

    Messages:
    12
    Positive Ratings:
    1
    couldn't they be a result of ctrl+shift+B'ing your entire map? i did that once and it moved everything around way too much for my liking.
     
  7. takabuschik

    aa takabuschik

    Messages:
    660
    Positive Ratings:
    308
    that's exactly what happened
    but it had to be done