Can't find leaks of Areaportals.

Discussion in 'Mapping Questions & Discussion' started by Nimelrian, Jun 25, 2010.

  1. Nimelrian

    Nimelrian L2: Junior Member

    Messages:
    64
    Positive Ratings:
    6
    Hey there, i've got a problem with my first map (again...).
    I built in Areaportals and if I compile a map, vbsp says that most of them are leaked (don't touch two areas).
    If I load the pointfile, i get the red line, but it leads just around one house and ends at the same portal as it started at.

    Maybe you can find the leaks, here's the .vmf.

    http://dl.dropbox.com/u/8466060/pl_riverbank.vmf

    Thanks!

    Nimelrian
     
  2. tarmo-

    tarmo- L3: Member

    Messages:
    108
    Positive Ratings:
    28
    areaportal can't be in the "same area". as in, if the both sides of the areaportal brush are "touching" each other, it's a leak. one side of the areaportal must be in a sealed area, where it can't "touch" the other side.

    hope the picture will explain it..
     
  3. Nimelrian

    Nimelrian L2: Junior Member

    Messages:
    64
    Positive Ratings:
    6
    Look at the vmf.

    The Rooms are completely sealed (imo), the pointfile-line doesn't go through openings in the walls, but THROUGH the walls.

    IF there are leaks, i can't find them.
     
    Last edited: Jun 25, 2010
  4. tarmo-

    tarmo- L3: Member

    Messages:
    108
    Positive Ratings:
    28
    some of your areaportals are func_detail instead of func_areaportal.
     
  5. tarmo-

    tarmo- L3: Member

    Messages:
    108
    Positive Ratings:
    28
    also, leaks go through func_detail. they must be sealed with either areaportal or worldbrushes.
     
  6. Nimelrian

    Nimelrian L2: Junior Member

    Messages:
    64
    Positive Ratings:
    6
    Thanks, that fixed it!