Can't change camera angle while in the Face Edit Sheet?

Discussion in 'Mapping Questions & Discussion' started by AntonJ3000, May 9, 2010.

  1. AntonJ3000

    AntonJ3000 I am inactive and make horrible maps

    Messages:
    401
    Positive Ratings:
    89
    I have recently started to map again but now I have a problem I haven't had before.
    When I try to change the camera angle using the arrow-keys while in the Face Edit menu (Shift-A), it doesn't move, instead it just misaligns the texture.

    I guess I must have accidently hit some button combination to change it into doing this, how can I change it back?
     
  2. The Political Gamer

    aa The Political Gamer

    Messages:
    4,468
    Positive Ratings:
    1,704
    They remapped the keys in the latest update. You have to use Z or click in the X,Y, or Z boxes.
     
    • Thanks Thanks x 1
  3. AntonJ3000

    AntonJ3000 I am inactive and make horrible maps

    Messages:
    401
    Positive Ratings:
    89
    Thanks, I forgot that you could use Z to move around, that helps a lot.
     
  4. lana

    aa lana Currently On: ?????

    Messages:
    3,077
    Positive Ratings:
    1,389
    Use Z to move whenever possible. It is faster and works like a spectator camera, making texture application fun, fun, fun!
     
    • Thanks Thanks x 1
  5. Seba

    aa Seba DR. BIG FUCKER, PHD

    Messages:
    2,363
    Positive Ratings:
    2,692
    Holding space and clicking in the 3D view also works; that's my personal preference.
     
  6. absurdistof

    aa absurdistof

    Messages:
    1,242
    Positive Ratings:
    396
    :O so glad I found this I was so tired of aligning the view for optimal wasd camera movement.
     
  7. YM

    aa YM LVL100 YM

    Messages:
    7,099
    Positive Ratings:
    5,920
    Holding space + wasd keys > space + mouse
     
  8. Pocket

    aa Pocket func_croc

    Messages:
    4,489
    Positive Ratings:
    2,377
    BTW it looks like they reverted this. Squeaky wheel FTW!
     
  9. EArkham

    aa EArkham Necromancer

    Messages:
    1,585
    Positive Ratings:
    2,318
    Sorry to bump, but this is not reverted for me. Very awkward, wish it worked the old way. I still have to use space + click 3D or Z.

    Do I need to manually update the SDK or change a setting or something to get it to the old way?

    Kep
     
  10. YM

    aa YM LVL100 YM

    Messages:
    7,099
    Positive Ratings:
    5,920
    space + wasd man space + wasd.
     
  11. EArkham

    aa EArkham Necromancer

    Messages:
    1,585
    Positive Ratings:
    2,318
    Wasd works the same whether the face editor is open or not, and space + wasd does nothing different that I can tell. I still can't use the arrow keys to rotate the camera, space pressed or otherwise.

    Maybe there's an option setting that I have checked/unchecked or something.

    Kep
     
  12. Fraz

    aa Fraz Blu Hatte, Greyscale Backdrop.

    Messages:
    944
    Positive Ratings:
    573
    Hit "z" and then the mouse controls where you look while wasd moves you.
     
    • Thanks Thanks x 1
  13. EArkham

    aa EArkham Necromancer

    Messages:
    1,585
    Positive Ratings:
    2,318
    :D

    [Edit] Also, it's not a huge "omgah I can't map" deal; more out of curiousity and seeing if I can force every little drop of efficiency out of my design process.

    Kep
     
    Last edited: May 22, 2010
  14. Pocket

    aa Pocket func_croc

    Messages:
    4,489
    Positive Ratings:
    2,377
    Yeah, it's been on-and-off for me, actually. I don't know why. I wish at the very least they'd make it so it depends on whether the mouse is over the dialog or not, like they do with the other keys.
     
    • Thanks Thanks x 1