Can you not tie an env_sprite to a func_tracktrain?

Discussion in 'Mapping Questions & Discussion' started by necro, May 13, 2008.

  1. necro

    necro L3: Member

    Messages:
    106
    Positive Ratings:
    13
    I'd like to have a glowing light on my cart, but parenting an env_sprite to it doesnt seem to work. Am I just doing something wrong maybe?

    (I'd use the siren light like goldrush, but apparently the particle system only comes in blue)
     
  2. Lord Ned

    Lord Ned L7: Fancy Member

    Messages:
    421
    Positive Ratings:
    174
    Make sure you specify .spr on the end of the sprite path or else they don't show up regardless. (Also set to glow)
     
  3. necro

    necro L3: Member

    Messages:
    106
    Positive Ratings:
    13
    if i take the parent parameter out, it works fine
     
  4. Lord Ned

    Lord Ned L7: Fancy Member

    Messages:
    421
    Positive Ratings:
    174
    Odd. You SHOULD be able to parent sprites.
     
  5. YM

    aa YM LVL100 YM

    Messages:
    7,099
    Positive Ratings:
    5,742
    Thats really strange I used to parent sprites to func_tracktrains all the time, maybe its one of the things thats broken with the TF2 hammer like func_rotate
     
  6. necro

    necro L3: Member

    Messages:
    106
    Positive Ratings:
    13
    Got it. Found this comment from Atomiclink:

    "Ok, I've spent some time playing around with it. Turns out in TF2 they added an extra entity: env_sprite_oriented. This one is allowed to be parented/moved around. As far as I can tell, outputs/inputs act exactly the same. Silly VALVe."
     
  7. Lord Ned

    Lord Ned L7: Fancy Member

    Messages:
    421
    Positive Ratings:
    174
    Sweet thanks.