Buildcubemaps and pakrat won't work

Discussion in 'Mapping Questions & Discussion' started by wiseguy149, Jun 17, 2010.

  1. wiseguy149

    wiseguy149 Emperor of Entities and Amateur of Aesthetics

    Messages:
    103
    Positive Ratings:
    157
    I have no clue what is happening to my map. When I type buildcubemaps in the console, it gives me this error message:

    Current mod isn't in a subdirectory of "game"!
    *** Error: Skybox vtf files for sky_trainyard_01 weren't compiled with the same size texture and/or same flags!
    Can't load skybox file sky_trainyard_01 to build the default cubemap!

    I know those skybox error messages are normal, but the subdirectory of game one is not (for me).

    Also, if I attempt to open the map with pakrat, I get a window like this but not the window to add files.
    [​IMG]
    Yet pakrat opens up any other map just fine

    Does anyone know wtf is going on?
     
    Last edited: Jun 17, 2010
  2. PL-7764

    PL-7764 L6: Sharp Member

    Messages:
    376
    Positive Ratings:
    67
    That's normal (from my experience anyway). Whenever I get it I just load another map and then reload mine, as one usually does after building cubemaps, and it works fine.

    No idea on the Pakrat thing, sorry...
     
  3. nik

    nik L12: Fabulous Member

    Messages:
    987
    Positive Ratings:
    246
    the skybox thing pretty much almost always happens to me, it's totally normal
     
  4. wiseguy149

    wiseguy149 Emperor of Entities and Amateur of Aesthetics

    Messages:
    103
    Positive Ratings:
    157
    I see those second two error lines all the time, but that first one is completely new. And loading other maps still doesn't fix it.
     
  5. Beetle

    Beetle L9: Fashionable Member

    Messages:
    627
    Positive Ratings:
    141
    Its definitely normal and has always done that for as long as I can remember. Just do what PL says which you would need to do with every map you make anyway.

    edit: even the subdirectory part
     
  6. wiseguy149

    wiseguy149 Emperor of Entities and Amateur of Aesthetics

    Messages:
    103
    Positive Ratings:
    157
    I tried loading another map and then reloading mine and it still doesn't work.