Brushes not visible in 3D viewer

Discussion in 'Mapping Questions & Discussion' started by Lugia, Jun 26, 2016.

  1. Lugia

    Lugia L1: Registered

    Messages:
    12
    Positive Ratings:
    0
    I recently started to get back into mapping, but whenever I create a brush, it is only the outline given by visgroups. It appears fine in game, and the same for every texture. Any ideas?
     
  2. killohurtz

    aa killohurtz Distinction in Applied Carving

    Messages:
    1,003
    Positive Ratings:
    1,155
    Maybe you have the 3D camera on wireframe or some other mode by accident? Click camera in the upper left corner to change it back to textured (or shaded textured, whichever you prefer).
    [​IMG]
     
  3. Nicky

    aa Nicky Lets try something new!

    Messages:
    912
    Positive Ratings:
    1,698
    Click the word "Camera" at the top right of your 3D viewport, and then select "3D Textured" or "3D Shaded Texture Polygons". I prefer the latter.


    Edit: Ninja'd by Killo, darn.
     
  4. Lugia

    Lugia L1: Registered

    Messages:
    12
    Positive Ratings:
    0
    Yeah thats it. Thanks, didn't think of that lol.
     
  5. Nighttime71

    Nighttime71 L2: Junior Member

    Messages:
    83
    Positive Ratings:
    39
    Doesn't 3D Shaded Textured Polygons screw up how overlays show up on Hammer?
     
    • Agree Agree x 1
  6. killohurtz

    aa killohurtz Distinction in Applied Carving

    Messages:
    1,003
    Positive Ratings:
    1,155
    Yes, it does make overlays flicker, and it also has issues rendering certain material proxies and parameters (e.g. the fading no entry overlay and rotated glass texture). It's more useful when you have several brush faces with the same texture and need the shading to tell them apart.
     
  7. Nicky

    aa Nicky Lets try something new!

    Messages:
    912
    Positive Ratings:
    1,698
    It does, but it makes it so much easier to differentiate the brushes from eachother. You can always just switch to the other view setting to see the overlays correctly.

    3D Textured:


    3D Shaded Textured Polygons:
     
    • Agree Agree x 2
    • Useful Useful x 2