Brush entities turn back into normal brushes after being deselected

Discussion in 'Mapping Questions & Discussion' started by goatcheese3, Mar 5, 2013.

  1. goatcheese3

    goatcheese3 L1: Registered

    Messages:
    36
    Positive Ratings:
    3
    I have been having a big problem lately.
    Whenever I create a brush entity (func_door, func_detail, etc.), it immediately turns back into a normal brush after I deselect it (as stated in the thread title).
    The brush entites worked fine until about an hour ago, when they all reverted themselves to brushes for some reason.

    EDIT: Thanks for the help! I should have closed the map before posting for help here. Hopefully my common sense won't fail me next time!
     
    Last edited: Mar 5, 2013
  2. Idolon

    aa Idolon the worst admin

    Messages:
    1,432
    Positive Ratings:
    4,181
    I've had the same issue before, I fixed it by closing the map and re-opening it. If that doesn't work, restart Hammer.
     
    • Thanks Thanks x 1
  3. henke37

    aa henke37

    Messages:
    1,855
    Positive Ratings:
    430
    Check if you have ignore groups on, it will do this. Technically, it is the brush selection buttons that default to being docked in the right sidebar, but eh.
     
    • Thanks Thanks x 1
  4. Crash

    aa Crash func_nerd

    Messages:
    3,124
    Positive Ratings:
    4,693
    Did you perhaps have Solids selected in the top right corner? This would do what you described.

    For the uninformed:

    Groups selects anything grouped together, whether tied by entity or grouping them manually.

    Object selects only the object/ entity you click on. So say you have a bunch of separate func_details grouped together manually, this can be used to select only one of them.

    Solids ignores all grouping and entity groups and selects only the brush/ entity you click on. So say you have a structure tied to one big func_detail, this can be used to pick a single brush out of that. When you go back to Groups or Objects, the entity will still be there.
     
    • Thanks Thanks x 2