Brush entities reverting to brushes?

Discussion in 'Mapping Questions & Discussion' started by Spammish, Jan 2, 2010.

  1. Spammish

    Spammish L3: Member

    Messages:
    117
    Positive Ratings:
    33
    This is a problem I've been having quite frequently on my first map, I am new and am probably making an obvious error here but it's annoying as hell to not be able to edit func's and stuff. For example, I've set up a respawn area and whenever I right click<properties it comes up with the visgroup tab and if I try ctrl+t (I know that's tie to entity) it comes up as a func_detail, although I can't speak for all the brush entities with this problem the respawn room still functions fine when I compile and run the map.
    Thanks in advance.
     
  2. Psy

    aa Psy The Imp Queen

    Messages:
    1,705
    Positive Ratings:
    1,468
    Make sure you have 'groups' selected on the right-side of the screen under 'Select:'.
     
  3. Spammish

    Spammish L3: Member

    Messages:
    117
    Positive Ratings:
    33
    Thanks, although it wasn't selected when I just started up hammer I may have accidentally selected it before and the problem seems to have gone, at least for now. Rather than opening up a new thread, I was wondering what the easiest way to set up a spawn system like in badlands, granary and other 5cp maps where spawn position changes depending on point captured, I currently have spawn entities set up in my secondary spawn with associated control point set to middle but during testing, I would always spawn in my first spawn.
     
  4. Nutomic

    Nutomic L11: Posh Member

    Messages:
    888
    Positive Ratings:
    177
    The easiest way would be to grab a vmf of a 5cp-map here and just copy everything ;)
     
  5. Spammish

    Spammish L3: Member

    Messages:
    117
    Positive Ratings:
    33
    Thanks for all the help guys. :thumbup:
     
  6. Bockagon

    Bockagon L3: Member

    Messages:
    147
    Positive Ratings:
    72
    Or you could use Boojum's Resource Pack. Even if you don't use it for setting up your game entities you should definitely install it.
     
  7. Swiftmind

    Swiftmind L2: Junior Member

    Messages:
    73
    Positive Ratings:
    20
    This has happened to me too but with any brush entity, it may be a bug within Hammer. Once and a while all my brush entities will appear as solids when selected (info bar at the bottom reports solid brush of 6 sides) and all groups will no longer register and I can only select individual brushes at a time. I am not sure what causes it.

    Easy fix, restart hammer. Everything is fine when I restart hammer. So before you go messing around with your entities, look to see if other brush entities appear as solids. If so just restart Hammer. If restart does not work, fully exit steam and hammer, restart hammer.
     
  8. Psy

    aa Psy The Imp Queen

    Messages:
    1,705
    Positive Ratings:
    1,468
    It's caused by the 3 buttons on the right-hand side.

    [​IMG]

    Groups will select grouped objects and brush entities, Objects will select objects individually even if they are a part of a group, and Solids will select objects individually as normal brushes causing you to be unable to view a brushes entity information.

    You can quickly switch between 'Groups' and 'Solids' by hitting Ctrl + W.
     
    • Thanks Thanks x 2
  9. Swiftmind

    Swiftmind L2: Junior Member

    Messages:
    73
    Positive Ratings:
    20
    Ah there we go. I must hit w once and a while mistakenly.
     
  10. Terr

    aa Terr Cranky Coder

    Messages:
    1,591
    Positive Ratings:
    405
    Also check that :ig: is not on when trying to edit brush-entity properties.
     
  11. A Boojum Snark

    aa A Boojum Snark Toraipoddodezain Mazahabado

    Messages:
    4,769
    Positive Ratings:
    5,535
    Ignore groups and the Solids button are actually one in the same. Turning on one will turn on the other.