Broken HL2 Model Browser?

Discussion in 'Mapping Questions & Discussion' started by NH4ClO4, Aug 10, 2013.

  1. NH4ClO4

    NH4ClO4 L1: Registered

    Messages:
    8
    Positive Ratings:
    0
    So after the steampipe update, we all know very well that the SDK no longer works. I've been using the Hammer editor included with TF2, but one thing's been bugging me. The Model Browser and Model Viewer are both broken- in the case of the model browser, the UI is "bloated"- by this I mean every element is much larger than it should be for that window, yet event detection still works as if the UI wasn't like this, so there's a bit of a disconnect between what I click and what is selected. Secondly I can't use any of the text boxes, as they're hidden behind another "bloated" UI element.
    The Model Viewer is much less broken, the UI is normal and fully functional but the displayed model is centered to the lower left corner instead of the center of the window.

    Is there any fix or alternate browser?
     
  2. Seba

    aa Seba DR. BIG FUCKER, PHD

    Messages:
    2,363
    Positive Ratings:
    2,365
    Have you tried verifying the TF2 cache? I can't think of any other reason why the tools would be broken (apart from Valve being Valve, ofc).
     
  3. NH4ClO4

    NH4ClO4 L1: Registered

    Messages:
    8
    Positive Ratings:
    0
    I verified the TF2 cache but that didn't solve any problems.

    This is what I'm seeing:

    [​IMG]
     
    Last edited: Aug 10, 2013
  4. Toxindude

    Toxindude L3: Member

    Messages:
    103
    Positive Ratings:
    4
    My model viewer looks just like this too. It used to be all green and you could see the entire model in the preview box but now portions of the models will be blacked out. Even worse is when you put the model in the game it shows up when you drag it around but when your not half the model will be completely black making placement very hard.
     
  5. Toxindude

    Toxindude L3: Member

    Messages:
    103
    Positive Ratings:
    4
    Did 2 Game Cache checks it found one problem but did not fix this issue.
     
  6. mint onion

    mint onion L3: Member

    Messages:
    101
    Positive Ratings:
    38
    once more to the rescue, ABS's resource pack has a very useful prop library i'd recommend using. it's much better than navigating the model browser. just copy the props you'd like from the library maps, and then paste them into your map. not only are the props easy to browse and select, but their entity settings are reasonably set for your convenience.
     
    • Thanks Thanks x 1
    Last edited: Aug 19, 2013
  7. mint onion

    mint onion L3: Member

    Messages:
    101
    Positive Ratings:
    38
    if i encountered this problem, and couldn't find a workable solution, i'd straight-up just re-install hammer. if that doesn't fix it, i don't know what would.