Blur made by the Water

Discussion in 'Mapping Questions & Discussion' started by FrostHoneyJuice, Mar 26, 2016.

  1. FrostHoneyJuice

    FrostHoneyJuice L2: Junior Member

    Messages:
    98
    Positive Ratings:
    86
    What's the problem?
    Every time when I get close to the water, my screen always gets blurred. Sometimes it doesn't, but instead, it shows me something completely disturbing!

    Here's an example:
    [​IMG]

    Click the link for the GIF file: http://i.imgur.com/1MWY13O.gifv

    Do you have any leaks?
    Nope.

    Do you use "func_water_analog" for your water?
    Nah.

    Do you have something on top of the water brush?
    Yes, I do. I have :blocklight: brush.

    Do you have something "special" inside of your water?
    Yup. Previously I had func_illusionary inside of it, but then I replaced it with func_brush. Besides that, I also placed some props and light entities inside of it too!

    What texture do you use?
    swamp/water/water_swamp

    Do you get any errors in your console?
    I get this, when the map spawns:
    Code:
    KeyValues Error: LoadFromBuffer: missing { in file materials/SWAMP/WATER/WATER_SWAMP.vmt
    (*water*), (*WaterLOD*), (*dummy*), (*TextureScroll*),
    Later, I get this, but tbh I am not sure what's up with that: (it spams my console a little bit & I think that it appears when I enter the water or perhaps when I stare at the water, but I doubt it!)
    Code:
    No such variable "$C0_X" for material "dev/lumcompare"
    No such variable "$C0_Y" for material "dev/lumcompare"
    Code:
    No such variable "$fogcolor" for material "maps/koth_undercicle_a5/swamp/water/water_swamp_-4348_-6134_-92"
    No such variable "$fogenable" for material "maps/koth_undercicle_a5/swamp/water/water_swamp_-3548_-6134_-92"
    No such variable "$fogstart" for material "maps/koth_undercicle_a5/swamp/water/water_swamp_-4348_-6134_-92"
    Do you have any cubemaps on your water brushes?
    Yes, I do. I use only 1 cubemap for each water brush.

    What's up with that grinder model?
    I dunno. Previously it showed up in my skybox for some fucked up reason. The grinder model wasn't even placed in the skybox. Instead, it was placed only in the playing area. Basically, I solved that anomaly by moving my skybox a bit higher. And now, it also likes to appear here! Wow. That fucking grinder is literally haunting my map!

    Anyway, if someone has an answer to the blur problem, then please do it fast!
    There is not much left for the April Fools contest! :engienope:

    Thank you!
     
  2. UKCS-Alias

    aa UKCS-Alias Mann vs Machine... or... Mapper vs Meta?

    Messages:
    1,264
    Positive Ratings:
    748
    Although not covering a fix i had that issue quite 'recently'. There might be some usefull information in an attempt to fix it though:
    http://tf2maps.net/threads/broken-water-not-a-leak.26524/
    And note, my issue is very likely not identical since in my map it works properly at close range.

    Im still curious of your problem gets fixed by one of the suggestions given in the thread, since in my case it didnt and i removed the water entirely.

    The bug you see is that what has to render below the water is simply stuck on 1 place on the screen. It does get the water distortion, but it doesnt update what it has to render below it.
     
  3. DrLambda

    aa DrLambda L69: Teeheehee, Member

    Messages:
    458
    Positive Ratings:
    454
    Is this part of the TF2 base game or did you download the swamp pack? There might also be an error if you have both installed. Or maybe the vmt is actually broken.
     
  4. FrostHoneyJuice

    FrostHoneyJuice L2: Junior Member

    Messages:
    98
    Positive Ratings:
    86
    Maybe yeah, copying the brushes is a good idea. Still can't understand the issue.

    EDIT: Wrong post. I just remembered that one guy told to someone else that he can copy the water from another map (example: ctf_2fort) and paste it in his own map. I am not sure if making the water brush from the scratch will do anything!

    I have downloaded only the missing content from the swamp pack, so I am pretty sure that I am using the official stuff!
     
    Last edited: Mar 26, 2016
  5. Requiesta

    Requiesta L1: Registered

    Messages:
    26
    Positive Ratings:
    12
    Do you have multiple cubemaps in the area with the water?
     
  6. FrostHoneyJuice

    FrostHoneyJuice L2: Junior Member

    Messages:
    98
    Positive Ratings:
    86
    No!
     
  7. Vel0city

    aa Vel0city func_fish

    Messages:
    1,900
    Positive Ratings:
    1,512
    Turning of refractions can cause the weird reflection you're seeing. The command is r_waterdrawreflection.

    Is this only on your end or are other people also seeing this?
     
  8. FrostHoneyJuice

    FrostHoneyJuice L2: Junior Member

    Messages:
    98
    Positive Ratings:
    86
    I have already r_waterdrawreflection set to 1. The map isn't released yet, so I don't know if people can see it or not!
     
  9. Vel0city

    aa Vel0city func_fish

    Messages:
    1,900
    Positive Ratings:
    1,512
    If you can, send the bsp (packed with the custom content) to me via a PM with something like Dropbox and I'll have a look later today.
     
  10. FrostHoneyJuice

    FrostHoneyJuice L2: Junior Member

    Messages:
    98
    Positive Ratings:
    86
    Done!
     
  11. Tumbolisu

    aa Tumbolisu  I ⌄ I 

    Messages:
    935
    Positive Ratings:
    904
    Do you have multiple water heights within the same potentially visible set? And what about cheap and expensive water?
     
  12. FrostHoneyJuice

    FrostHoneyJuice L2: Junior Member

    Messages:
    98
    Positive Ratings:
    86
    Just a normal brush with a normal height, where only the top is textured with a water texture! And if I am not wrong, that's probably an expensive water!
     
  13. Another Bad Pun

    Server Staff Another Bad Pun bad

    Messages:
    573
    Positive Ratings:
    1,157
    If you have different levels of expensive water visible in the same area it will usually cause buggy reflections like yours. By visible, i mean in terms of the Source Engine - walls and other obstructions might not be enough to block "visibility."
    Sometimes you can fix it by making one of the water textures a cheap water texture. That fix didn't work out for me when I had it though. The GIF looks 95% like this issue, but maybe it isn't. ¯\_(ツ)_/¯

    It could be something different. Maybe troubleshoot different water textures, create a func_water_analog over the pool (although that might not do anything to be honest.) Hope this helps
     
  14. Tumbolisu

    aa Tumbolisu  I ⌄ I 

    Messages:
    935
    Positive Ratings:
    904
    So this is the only water brush in the entire map? I didn't ask about the height of that specific water, I asked if theres multiple water brushes of varying height.
    If this really is the only water brush, and its perfectly flat at the top, then the last thing I can think of is trying to use a different water material. Also, this doesn't really look like expensive water but that's because of the problem we have here. Try using a func_water_analog...
    god damn abp
     
    • Agree Agree x 1
  15. Vel0city

    aa Vel0city func_fish

    Messages:
    1,900
    Positive Ratings:
    1,512
    I just had a run around. There's definitely more than one level of water but it's all cubemapped and not visible at the same time. Also, it worked perfectly fine on my end.
     
  16. FrostHoneyJuice

    FrostHoneyJuice L2: Junior Member

    Messages:
    98
    Positive Ratings:
    86
    Sorry for misunderstanding! No, that's not the only water block in this level. There are total 8 water brushes with different heights!

    While I was developing the map, I already used func_water_analog. The reason why I stopped using func_water_analog is because of this problem! I thought that turning func_water_analog entities into normal world brushes will solve the problem! But apparently it did not!

    Ah, for fuck sake, maybe it's a texture problem indeed! But I am pretty sure that there is something else! Just wait till I post an update!
     
  17. Tumbolisu

    aa Tumbolisu  I ⌄ I 

    Messages:
    935
    Positive Ratings:
    904
    HNNG I just noticed I mixed something up with entity names. I didn't mean func_water_analog, I actually meant water_lod_control. It's a point entity that sets the distance from which a water brush should appear as cheap.
    But nothing is gonna help if you have multiple heights of water. In fact, it is a requirement of water that in a potentially visible set there can be only a single water height.

    Links seperated from text:
    https://developer.valvesoftware.com/wiki/Water_lod_control
    https://developer.valvesoftware.com/wiki/Adding_Water#Requirements
    https://developer.valvesoftware.com/wiki/PVS
     
  18. Another Bad Pun

    Server Staff Another Bad Pun bad

    Messages:
    573
    Positive Ratings:
    1,157
    Yeah, I did too. Oops