Black room glitch

Discussion in 'Mapping Questions & Discussion' started by Exactol, Jun 25, 2015.

  1. Exactol

    aa Exactol Certified Hammer Hacker

    Messages:
    393
    Positive Ratings:
    451
    So, I have a area of my map that is just pitch black for some reason. http://images.akamai.steamuserconte...513/D95E26324A0F8837B68CF43A0845F86CE214F3C0/ Models and players are lit fine, but the brushes are just black. The lighting looks fine on fast compile, but on full it just becomes black. If the section that is black is compiled alone it turns out fine.
    If anyone could help, I'll give you a imaginary cookie.
    VMF: http://www.mediafire.com/download/s7hikyyuxtq1qfv/trade_unusual_center_ut_a1.vmf
    This is the area which is being problematic: http://i.imgur.com/H5fL5Mr.png
     
  2. iiboharz

    aa iiboharz Meme Queen

    Messages:
    700
    Positive Ratings:
    1,025
  3. Exactol

    aa Exactol Certified Hammer Hacker

    Messages:
    393
    Positive Ratings:
    451
    Already did and no errors
     
  4. Blade x64

    aa Blade x64 Logical insanity

    Messages:
    199
    Positive Ratings:
    441
    You put the light sources inside of the light models. Make sure the origin of the lights are not inside the collision model, or disable shadows on the light models.
     
    • Thanks Thanks x 2
  5. Lampenpam

    aa Lampenpam

    Messages:
    991
    Positive Ratings:
    328
    I'm pretty sure there is a corrupt brush in the area with the light error. Look for complext brushes and compile without them or try to hunt the brush down by using the cordon tool.
     
    Last edited: Jun 26, 2015