Back at it again with the forward spawn problems

Discussion in 'Mapping Questions & Discussion' started by Dovahbilly, Apr 6, 2016.

  1. Dovahbilly

    Dovahbilly L1: Registered

    Messages:
    30
    Positive Ratings:
    2
    Hey guys, so i've been working on my map, cp_sandvichstorage, (you may remember it from some gamedays) for a really long time now, and almost have it finished in the new version. There's just one problem.

    I just can't work out forward spawns.

    I've posted about them here before. But when I thought I had fixed them, they fucked up when a gameday came along, with Blue spawning in them way too early! (I believe that's what happens in the current version, a6)

    So I redid them completely in a7, but alas, they still don't work.

    I don't know what i'm doing wrong! I set the spawns and spawn door to Start Disabled, then when the second point is captured i've sent outputs to enable all the spawn points, the spawn room, and disable the old spawn points.

    But whenever the second point is captured, the first spawns disable easily, but the new ones don't enable, and blue team just spawns in Red's spawn instead, even though those spawns are only set to spawn... Red players.

    I really don't know what i'm doing wrong. There's barely any tutorials for this stuff online so i'm kinda running into this blindly. If anyone wants the vmf to take a look at, they can PM me. Has anyone experienced this before??
     
  2. DrLambda

    aa DrLambda L69: Teeheehee, Member

    Messages:
    458
    Positive Ratings:
    454
    This question is hard to answer without additional information, because what you described should basically work. Could you give us either the VMF or a basic VMF containing all required entities to check them?
     
  3. Dovahbilly

    Dovahbilly L1: Registered

    Messages:
    30
    Positive Ratings:
    2
    I believe this is the latest VMF. I don't use any custom props or textures, so it should be fine. Thank you ahead of time :)

    I'm sure it's probably something quite obvious that I missed! haha
     
  4. DrLambda

    aa DrLambda L69: Teeheehee, Member

    Messages:
    458
    Positive Ratings:
    454
    I'm currently looking into it. I want to start by saying that:

    1. You have a skybox-box. This is very bad for performance and increases compile time drastically. I'd suggest changing that as soon as possible. I can't really compile the map on the slow system i'm currently on, so i'll continue testing by copy-pasting the necessary entities over to a blank map.
    2. You're making the outputs more complicated than they need to be. If you want to disable all info_player_teamspawns inside a spawn room, instead of sending an output to every single one, you could:
    a) Give them all the same name and disable them over a single output
    b) Use wildcards within the output, significantly cutting down the sheer amount of outputs. PE: forward_spawn_*.Enable rather than forward_spawn_1.Enable, forward_spawn_2.Enable, forward_spawn_3.Enable etc

    I'll post again once i have the necessary information.
     
    • Useful Useful x 1
  5. Dovahbilly

    Dovahbilly L1: Registered

    Messages:
    30
    Positive Ratings:
    2
    Thank you for all your help! I'll keep all this information in mind :) I didn't even know the wildcard thing was an option! That'll definitely come in handy, I always wondered why I felt outputs and inputs were more complicated than they needed to be. Thank you again!
     
  6. DrLambda

    aa DrLambda L69: Teeheehee, Member

    Messages:
    458
    Positive Ratings:
    454
    So, i solved the problem.

    I put all the entities into a new map, compiled and got the same errors as you got. Because i wasn't able to see anything radically wrong, i checked a decompiled version of cp_gorge. First thing i realized is that the spawns on cp_gorge didn't have the "RED/BLU spawn for round..." set, so i removed that. This didn't help.
    When trying to check the team_control_point_round on gorge, i found the problem. There isn't a tcp_round on gorge. So i deleted it, set "Restrict team from winning" to red on the team_control_point_master, and voila, everything works as intended.

    So:
    1. Remove "RED/BLU spawn for round..." values from info_player_teamspawn.
    2. Delete the team_control_point_round entity.
    3. Set "Restrict team from winning" to RED on team_control_point_master.
     
    • Useful Useful x 1
  7. Dovahbilly

    Dovahbilly L1: Registered

    Messages:
    30
    Positive Ratings:
    2
    Oh thank you so much! This has been plaguing me for so long. I'll keep all your advice into consideration and hopefully the new version will be ready for shipping soon. :)

    You've been very helpful, thank you again.