Attached screenshots should be embeds, not links

Discussion in 'Site Discussion' started by Pocket, Feb 20, 2016.

  1. Pocket

    aa Pocket func_croc

    Messages:
    4,489
    Positive Ratings:
    2,217
    I know people don't pay as much attention to map threads as they used to now that the feedback plugin is a thing, but one thing that always kept them interesting — and helped me remember which of the 10 generically named [game mode] maps currently in rotation was which — was the addition of new screenshots every update or so. Right now, we have an even easier way to add those screenshots: Just upload them directly when you update the map and it'll make a new post for you. Except it doesn't actually display those screenshots inline; instead it's just a single line of text "View attachment XXXXX View attachment XXXXY View attachment XXXXZ"...

    I see no reason why those can't be a stack of inline images instead. Can that be a thing? In fact, I'd like to see it applied retroactively, if there's a way that could happen.
     
    • Agree Agree x 4
  2. Turnip

    aa Turnip The 80s Vegetable

    Messages:
    1,430
    Positive Ratings:
    795
    Maybe a sub section in the overview tab for: Update a1 Screenshots Uploaded: Image, and for all the other updates you just click to see the screenies, and it would display the most rescent updates screenies
     
  3. Pocket

    aa Pocket func_croc

    Messages:
    4,489
    Positive Ratings:
    2,217
    Oh, and I'm not sure what benefit it has to truncate those posts either; for all I know, that's causing screenshots to not even show up as links most of the time because the description/patch notes exceed the arbitrary line limit.
     
  4. Muddy

    Server Staff Muddy Muddy

    Messages:
    2,381
    Positive Ratings:
    4,210
    I honestly thought it was a bug..
     
  5. Viperi

    aa Viperi not actually a snek

    Messages:
    962
    Positive Ratings:
    533
    I heavily agree on this, it's rather annoying when somebody wants to add screenshots on updates and it turns out to be a link on the discussion side. Even though video links work properly.
     
  6. Geit

    aa Geit 💜 I probably broke it 💜

    Messages:
    597
    Positive Ratings:
    1,112
    It's an annoying but intended feature of Xenforo, the basic idea is that it'll only appear as an embed on the original content item because otherwise you could simply spoof the [attach]x[/attach] tag (because x is always sequential) and access attachments you don't have the rights to view.

    Placing it as a link forces Xenforo to check if you have permissions to view the original content item it was attached with before redirecting you to the actual image.

    I'm not sure how to fix it short of rewriting Xenforo's attachment system, and there's no built in way to disable attachment security.
     
  7. Viperi

    aa Viperi not actually a snek

    Messages:
    962
    Positive Ratings:
    533
    Well that's slightly annoying, even though it's a intended feature.
     
  8. Geit

    aa Geit 💜 I probably broke it 💜

    Messages:
    597
    Positive Ratings:
    1,112
    Test

    thumbs_DSC_1410_.JPG
    thumbs_DSC_1410_.JPG
     
    • Thanks Thanks x 1
    • Like Like x 1
    Last edited: Feb 21, 2016
  9. Geit

    aa Geit 💜 I probably broke it 💜

    Messages:
    597
    Positive Ratings:
    1,112
    test
     
    Last edited: Feb 21, 2016
  10. Geit

    aa Geit 💜 I probably broke it 💜

    Messages:
    597
    Positive Ratings:
    1,112



    Shouldn't be viewable.
     
    Last edited: Feb 21, 2016
  11. norfolk terrier

    norfolk terrier L3: Member

    Messages:
    135
    Positive Ratings:
    196
    Geit, out of every image on the planet, why use that image? Just curious.
     
  12. Zed

    aa Zed Certified Most Crunk™

    Messages:
    1,242
    Positive Ratings:
    1,003
    Of course that's the image that pops up when I open this thread as someone's walking by.
     
    • Funny Funny x 1
  13. Geit

    aa Geit 💜 I probably broke it 💜

    Messages:
    597
    Positive Ratings:
    1,112
    All fixed, I think.

    using attachment thumbnails will add a bit of overhead to the page load time for the server as it has to do permission checks and whatnot, but I don't think it should be significant on most pages. (it adds about 0.01 seconds [10ms] to this thread)
     
    • Thanks Thanks x 1