Artpass Mistermojo

Discussion in 'Map Factory' started by Mistermojo, Jul 19, 2010.

  1. Mistermojo

    Mistermojo L1: Registered

    Messages:
    10
    Positive Ratings:
    0
    Got an issue with cubemaps see post #5

    Original Post:

    It's been almost 2 years since I last used SDK (never mapped for TF2 before although I have invested alot of time into playing the game :p ). I know have no chance of winning but I'm hoping this little project will get me back into the map-making mindset.

    I've mapped for CSS before, I would link you to some of my work but I'm guessing FPSB is still a no-go.

    Basically I don't really have a theme as yet but I thought I'd make the thread now rather than later. I'm thinking sticking to the default textures thought as I won't have as much time as everyone else to devote to this due to work and the fact that I'm starting Uni in September, but I'll give it my best shot :)

    The Latest

    My theme has changed somewhat from my original Industrial-based theme. I'm now going for an Alpine-canyon-spytec-base theme, as I think a canyon-styled map fits the high walled areas and could provide an interesting atmosphere.
     
    Last edited: Jul 22, 2010
  2. T3hReaper91

    T3hReaper91 L1: Registered

    Messages:
    7
    Positive Ratings:
    0
    Its coming along. This could look good when finished as this is in early stages..

    Good luck.
     
  3. Mistermojo

    Mistermojo L1: Registered

    Messages:
    10
    Positive Ratings:
    0
    Cheers, I got a long way to go though lol. Walking through the map I realised how much work I have to do lol. Yours looks good too :)
     
  4. Greenagainn

    Greenagainn L1: Registered

    Messages:
    7
    Positive Ratings:
    1
    Before you take in-game screenshots go into the console and type buildcubemaps and then restart the map.

    Anyway, good start :)
     
  5. Mistermojo

    Mistermojo L1: Registered

    Messages:
    10
    Positive Ratings:
    0
    Ah, that's how you do it, cheers haha. It has been a really long time lol.
     
  6. Mistermojo

    Mistermojo L1: Registered

    Messages:
    10
    Positive Ratings:
    0
    Ok, I've got a few issues that I'd like some help in fixing if anyone has any idea what I'm doing wrong. Firstly, as you can tell from my new screenshots, my cubemaps won't work (the new screens only look ok cos I had to use mat_specular 0). When I compile the map I get the following message:

    "*** Error: Skybox vtf files for skybox/sky_night_01 weren't compiled with the same size texture and/or same flags!
    Can't load skybox file skybox/sky_night_01 to build the default cubemap!"

    I get the same message in-game when I use buildcubemaps in the console. This prevents the cubemaps from generating so I still get the purple and black squares. Any ideas?


    Secondly, in my map I have I bad displacement: EDIT: SOLVED
    [​IMG]

    But here's what the same place looks like in Hammer:
    [​IMG]

    So why is it different in-game? Help!? :p
     
    Last edited: Jul 22, 2010
  7. Mistermojo

    Mistermojo L1: Registered

    Messages:
    10
    Positive Ratings:
    0
    No-one have any ideas? :(
     
  8. Mistermojo

    Mistermojo L1: Registered

    Messages:
    10
    Positive Ratings:
    0
    Updated my screenshots, textured everything to try and get a feel for the theme.

    Still haven't solved either of my problems, had to disable mat_specular to take decent screenshots. I'm gonna try a different sky texture as the current one no longer fits with my new theme, hopefully that will fix the purple squares.

    I'm going to add a load of high walled areas to make it look more like a canyon, I just need to make sure I don't overdo the rock texture. Red's base is going to be carved into the side of the rock hopefully :)
     
  9. WastedMeerkat

    WastedMeerkat L3: Member

    Messages:
    144
    Positive Ratings:
    142
    Ignore it, it means nothing. Everybody gets this error.
     
  10. Pc_Madness

    Pc_Madness L4: Comfortable Member

    Messages:
    164
    Positive Ratings:
    48
    For the second error, I asked in chat for you and they said its because before the brush was a displacement, it was vertex edited to a funny angle. So the solution is to destroy the brush, make sure the vertices aren't doing anything crazy / check for invalid solids (Alt + P) and then redo the displacement.

    I believe. :)
     
    • Thanks Thanks x 1
  11. Ashy Knuckles

    Ashy Knuckles L2: Junior Member

    Messages:
    58
    Positive Ratings:
    13
    I'm having the same problem on my map actually. Ive read that you should ignore it, but its stopping me from building cubemaps, so it needs to be eventually fixed right?
     
  12. Mistermojo

    Mistermojo L1: Registered

    Messages:
    10
    Positive Ratings:
    0
    Nice to see that it's not just me, this is the issue I have. Those damn purple squares will be the death of me :(


    Thanks :D fixed my displacement by sewing the two edges together and playing around with it a bit, mainly cos I was wary of destroying the displacement :)
     
    Last edited: Jul 22, 2010
  13. Goombac

    Goombac L4: Comfortable Member

    Messages:
    172
    Positive Ratings:
    60
    • Thanks Thanks x 1
    Last edited: Jul 22, 2010
  14. Mistermojo

    Mistermojo L1: Registered

    Messages:
    10
    Positive Ratings:
    0
  15. Mistermojo

    Mistermojo L1: Registered

    Messages:
    10
    Positive Ratings:
    0
    Well to cut a long story short:

    I went away for a few days last month, came back and I have basically no motivation to finish this for the deadline, mainly because I'm going to uni soon to complicate things :)

    I probably should have thought of that before I started but oh well :p This might get finished at a later date just for a sense of completion.

    I wish all the other entrants the very best of luck!

    Cheers,
    Mojo.