Another Help Thread [MVM Population]

Discussion in 'Mapping Questions & Discussion' started by NoderNaeta, Jun 22, 2017.

  1. NoderNaeta

    NoderNaeta L1: Registered

    Messages:
    39
    Positive Ratings:
    16
    [​IMG]
    Hi.

    I've made an mvm map over the past months and got around to finishing its layout several days ago. As satisfying as it is to complete a layout, I've spent much more time than I'd like understanding the population file creation and to make it function for my map. I'd really like to put this to rest as it's cutting more time away than it should. So hopefully you wonderful people have a clue as to my problem.

    In loading my population "mvm_infuse_a1_goddess_of_machines_beta2", I receive the error in the dev console ingame as follows:
    WaveSchedule, WaveSpawn, Squad, TFBot,
    (*WaveSpawn*), (*Squad*), (*TFBot*), (*item*), (*TFBot*), (*attributes*), (*OnBombDroppedOutput*), (*action*), (*ItemAttributes*),
    Invalid populator 'WaveSpawn'
    Parse Failed in CPopulationManager::Initialize for scripts/population/mvm_infuse_a1_goddess_of_machines_beta2.popAttempted to create unknown entity type !
    Can't init
    WaveSchedule, WaveSpawn, Squad, TFBot,
    (*WaveSpawn*), (*Squad*), (*TFBot*), (*item*), (*TFBot*), (*attributes*), (*OnBombDroppedOutput*), (*action*), (*ItemAttributes*),
    Invalid populator 'WaveSpawn'
    Parse Failed in CPopulationManager::Initialize for scripts/population/mvm_infuse_a1_goddess_of_machines_beta2.popItem Whitelist file 'item_whitelist.txt' could not be found. All items will be allowed.
    WaveSchedule, WaveSpawn, Squad, TFBot,
    (*WaveSpawn*), (*Squad*), (*TFBot*), (*item*), (*TFBot*), (*attributes*), (*OnBombDroppedOutput*), (*action*), (*ItemAttributes*),
    Invalid populator 'WaveSpawn'
    Parse Failed in CPopulationManager::Initialize for scripts/population/mvm_infuse_a1_goddess_of_machines_beta2.popAttempted to create unknown entity type !
    Can't init
    WaveSchedule, WaveSpawn, Squad, TFBot,
    (*WaveSpawn*), (*Squad*), (*TFBot*), (*item*), (*TFBot*), (*attributes*), (*OnBombDroppedOutput*), (*action*), (*ItemAttributes*),
    Invalid populator 'WaveSpawn'
    Parse Failed in CPopulationManager::Initialize for scripts/population/mvm_infuse_a1_goddess_of_machines_beta2.popItem Whitelist file 'item_whitelist.txt' could not be found. All items will be allowed.
    This has been the point at which I'm stuck at. I am unsure on how to proceed despite searching online, comparing other population files, and just wasting too much time. My map works correctly (for the most part, Tanks do not trigger a game win), bots spawn and can win the game if I load a similar Valve population, my custom bots are 'precached' so to say like other custom maps, the file is in Team Fortress 2 < tf < scripts < population, and the nav mesh works. I just don't understand what is supposed to be fixed in the population.

    I've included my population file as an attachment for anyone to view. Thank you so much if anyone can respond with some help, this has been very frustrating! I want to publish my map soon, but I can't until this problem is solved.
     

    Attached Files:

  2. pennsyrail

    pennsyrail L2: Junior Member

    Messages:
    58
    Positive Ratings:
    8
    I don't know much about mvm, but I would say from looking at your compile that the sequencing logic you are using is fould. It makes me wonder if there are some trigger errors? Is it compiling to a playable point?
     
    • Respectfully Disagree Respectfully Disagree x 1
  3. pennsyrail

    pennsyrail L2: Junior Member

    Messages:
    58
    Positive Ratings:
    8
    Fouled, sorry.
     
  4. pennsyrail

    pennsyrail L2: Junior Member

    Messages:
    58
    Positive Ratings:
    8
    Is goddess of machines your own entity or robot version? Almost looks like that is causing the problem. Though I could be telling you what u already know.
     
  5. NoderNaeta

    NoderNaeta L1: Registered

    Messages:
    39
    Positive Ratings:
    16
    I have no issue compiling the map. My problem is that I've now begun deciphering the hieroglyphics of code to make a functional population file. I don't know why my file won't run is the issue after trying on / off for the past couple of days.
     
  6. pennsyrail

    pennsyrail L2: Junior Member

    Messages:
    58
    Positive Ratings:
    8
    I see. Sorry, like I said, I am a noobish being. I was looking at the .pop file and wandering if it might be that a bot name is typed up incorrectly? I'm not too keen on this stuff, but just connecting the dots. Are you following this example?
    http://wiki.teamfortress.com/w/images/4/4a/Mvm_example.pop.txt
     
  7. NoderNaeta

    NoderNaeta L1: Registered

    Messages:
    39
    Positive Ratings:
    16
    Oh, yes very much so! Along with other community population files I examined to see how they were built. I tried to pick apart why this doesn't work for so long now I'm flabbergasted. There's a lot that can easily turn wrong in coding, I know that much.
     
  8. Fillmore

    Fillmore L3: Member

    Messages:
    118
    Positive Ratings:
    83
    Judging by the very beginning of the error message, you have bad brackets going on.
    In a Wavespawn with Squad in it?
     
  9. NoderNaeta

    NoderNaeta L1: Registered

    Messages:
    39
    Positive Ratings:
    16
    Oh okay now, is that meaning something isn't closed or they need to be in a precise spot?
     
  10. Fillmore

    Fillmore L3: Member

    Messages:
    118
    Positive Ratings:
    83
    You either have a case of something not being enclosed within brackets or excess brackets.

    Wavespawn
    {
    -whereandallthatjazz-
    Squad
    {
    TFbot
    {
    Template beepboop
    }
    }
    }
    Lacking a closing bracket for Wavespawn, Squad or TFBot means that the parser has no idea where does this Wavespawn end and it bricks the rest of the profile.
     
    Last edited: Jun 23, 2017
  11. Star Bright

    Star Bright L2: Junior Member

    Messages:
    74
    Positive Ratings:
    59
    Just took a look at your popfile and whoa, your brackets and tabbing are kind of all over the place for Wave 1. "wave01a1" has a bracket out of nowhere, and the squad in "wave01a2" is a bit messy, though at the first fist heavy towards the bottom I spy a { where a } should be. Try fixing those?

    Edit: Oh also I'm like 99% sure pyro bots can't use the reserve shooter due to a valve bug involving unlock shotguns.