An Impossible Leak

Discussion in 'Mapping Questions & Discussion' started by Bombcartography, Sep 2, 2013.

  1. Bombcartography

    Bombcartography L1: Registered

    Messages:
    25
    Positive Ratings:
    7
    EDIT:

    Okay. I feel stupid now. Placing a a single player start to replace my hidden ones fixed the leak errors.

    Original Post below:

    I'm not sure if I have an actual leak or if VBSP is returning a false positive. Running it alone with only the basic geometry gets a leak error but generates no point file, even if I use the cordon tool. Running the map with everything in it turned on does not generate any errors. And the map runs fine, except the water is acting like I have a leak; the water flickers, flashes, and sometimes freezes and moves around.

    Early in the map, I would occasionally run just VBSP with the basic geometry for a quick check if there were any leaks. At a certain point, it started saying I had a leak but provide no point file. I searched for the leak but couldn't find one. And if I ran the map with props, func details, etc. the error disappeared. The map ran fine. So I assumed VBSP was giving false positives and ignored it.

    But recently the water in my map started flickering and flashing. I tried a hundred different combinations of water lod distances and water textures and sizes, but the flickering remained. Looking straight down at the water from about 600+ units above, it freezes and moves around.

    I thought back to the leak errors and wondered if I might actually have one and the compile logs just weren't reporting it. So I ran the map again with just VBSP and the basic geometry. Again it said I had a leak but did not generate a point file. It gave me a bunch of messages like this:

    FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (3088.0 3072.0 -1316.0)
    Leaf 0 contents: CONTENTS_SOLID
    Leaf 1 contents:
    viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID
    This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID
    Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID
    Candidate brush IDs:

    The coordinates are all out in the void about a 1000 units from the map. I selected the area to see if there was something out there. Nothing seemed to be there. I hit delete anyway. I went through and cut every single brush in the map over 1024 units down to 756 or lower. I did a jillion different things and still these errors.

    I then made a big cubed hallowed skybox around the whole map that was guaranteed to seal it. The same error except with coordinates about 1000 units away from the new outer skybox.

    Finally, I made a "trashable" save, and started deleting huge sections of the map to see what might be causing this. It got to the point where I had deleted the whole map except the outer skybox. At which point, it stopped giving coordinates and just said "leaked". Which would seem impossible. And of course, it gave me no point file still.

    So to check if the file was corrupted, I deleted the skybox. Made a new one. Ran it. Finally no leaks! :O

    I'd dismiss the leak error if it weren't for the funny acting water. So I don't know what's going on. :confused:
     
    Last edited: Sep 2, 2013
  2. Ravidge

    aa Ravidge Grand Vizier

    Messages:
    1,544
    Positive Ratings:
    2,493
    well you solved it, but to explain what is going on:
    The compiler needs a point entity (any will do) to define what is the "inside" of the map.
    A room (or in this case, entire map) made entirely of brushes with no entities in it is culled and removed in the compile.