All new props won't show up

Discussion in 'Mapping Questions & Discussion' started by Eishaaya, Aug 19, 2019.

  1. Eishaaya

    Eishaaya L1: Registered

    Messages:
    27
    Positive Ratings:
    0
    I spawned in a heap of new props in my newest hammer session, and ran the map to test...the props weren't there. I also removed some props and edited and vehicle's movement path, that didn't work in game either.
    I ran it again, still no props.
    I checked if the props were all prop_static, they were.
    I copy-pasted a working prop and ran the map.
    The copy didn't show up.
    I restarted hammer and the map is still broken
    I restarted my computer...no dice.


    I am now here, completely stumped on what's causing the problem
     
    Last edited: Aug 19, 2019
  2. Eishaaya

    Eishaaya L1: Registered

    Messages:
    27
    Positive Ratings:
    0
    Ignore the random rocks, they're junk at the moment
     

    Attached Files:

  3. Crash

    aa Crash func_nerd

    Messages:
    3,230
    Positive Ratings:
    5,128
    Your compile is likely broken and tf2 is loading a previous version of the map. Could you post your compile log?
     
  4. Eishaaya

    Eishaaya L1: Registered

    Messages:
    27
    Positive Ratings:
    0
    Some guy on reddit helped me out and I can fix it now
     
  5. Eishaaya

    Eishaaya L1: Registered

    Messages:
    27
    Positive Ratings:
    0
    It's still broken
     
  6. Eishaaya

    Eishaaya L1: Registered

    Messages:
    27
    Positive Ratings:
    0
    New version (still broken)
     

    Attached Files:

  7. Vel0city

    aa Vel0city func_fish

    Messages:
    1,944
    Positive Ratings:
    1,557
    Can you still post your compile log? It's what Hammer spits out during/after a compile and gives an indication as to what's happening.
     
  8. Eishaaya

    Eishaaya L1: Registered

    Messages:
    27
    Positive Ratings:
    0
    Mate, I fixed it, the props were prop_dynamic, not prop_static
     
  9. Eishaaya

    Eishaaya L1: Registered

    Messages:
    27
    Positive Ratings:
    0
    Afterwards, a crap ton of other stuff broke
     
  10. Eishaaya

    Eishaaya L1: Registered

    Messages:
    27
    Positive Ratings:
    0
    Map at the moment
     

    Attached Files:

  11. Eishaaya

    Eishaaya L1: Registered

    Messages:
    27
    Positive Ratings:
    0
    Now thing teleport around the map when I run tf2
     

    Attached Files:

  12. OctoBlitz

    OctoBlitz L6: Sharp Member

    Messages:
    279
    Positive Ratings:
    108
    Like the others requested...

    PLEASE POST THE COMPILE LOG INSTEAD OF THE VMF.

    It will help us alot more if we had Hammer itself telling us what's going on instead of compiling the map ourselves.
     
    • Agree Agree x 2
  13. Eishaaya

    Eishaaya L1: Registered

    Messages:
    27
    Positive Ratings:
    0
    I got it fixed, but now the lighting is broken

    I'm posting the VMF for a great guy on reddit who's helping me
    This is mostly being used to upload files
     
  14. Crash

    aa Crash func_nerd

    Messages:
    3,230
    Positive Ratings:
    5,128
    Please use a service like Dropbox or Google Drive instead of our forums for sharing files with someone in the future. All this is doing is creating confusion as people are trying to help you.
     
Tags: