A very odd brush glitch

Discussion in 'Mapping Questions & Discussion' started by Archmage MC, Jun 18, 2011.

  1. Archmage MC

    Archmage MC L2: Junior Member

    Messages:
    61
    Positive Ratings:
    0
    http://steamcommunity.com/profiles/76561198013756738/screenshots/

    As you can see from the screenshots, there seems to be a few places where the brush doesn't render. However in hammer they render fine. They are parts of the brush that they appear on, so something must be going wrong when the map is being compiled. Running the compile log through interlopers.net gives me this error...

    zero area child patch

    Description:
    A solid in your level has a face with no area. My guess is that vrad.exe is trying to create a lightmap for a face that doesn't exist. Maybe you have an invalid brush?

    Solution:
    First check Hammers problemchecker (alt+p). If that doesn't solve your problems, you can either ignore the error, or try to find it anyway using cordon tools. You would be looking for brushes which might be too complex. I wouldn't recommend the second option.

    Anyone know what is going on and how to fix it?

    Unrelated but critical for the map. When I compile the map, the map works fine for me. However when I give it to a few beta testers, they say that a part of the map that I say should move doesn't move on their end. They get some sort of console error saying that the logic_relay doesn't exist. How can I fix that?
     
  2. grazr

    aa grazr Old Man Mutant Ninja Turtle

    Messages:
    5,436
    Positive Ratings:
    3,561
    this wouldn't be anything to do with vrad, even though it's often the process to crash your compile.

    It sounds more like the face isn't aligned to the world or more seriously the brush is invalid. Select the brush, go to the texture panel and click "align to world" or re-create the brush from scratch (IE delete the existing one and replace it). Replacing the brush will resolve both/either of those problems and a couple potential rarer causes as well, so it's a good fail safe method of dealing with the problem.

    That would be my first port-of-call.
     
  3. The Asylum

    aa The Asylum

    Messages:
    1,658
    Positive Ratings:
    439
    Hammer does silly things sometimes, even with stuff you know has worked before and really should work.
     
  4. Archmage MC

    Archmage MC L2: Junior Member

    Messages:
    61
    Positive Ratings:
    0
    Thanks Grazr, that fixed the problem. Now to just fix those panels...