A question about Jarate! o_o

Discussion in 'Team Fortress 2 Talk' started by TaxiService, Aug 1, 2010.

  1. TaxiService

    TaxiService L1: Registered

    Messages:
    2
    Positive Ratings:
    0
    Hi! i am TaxiService, and i post here looking for some help. D:
    (premise: using Search did not give me any useful result, and i hope this is the right section where to ask this.. XD)

    So, here is my problem: when underwater, jarated or bleeding, my vision gets very dark; so dark that i get almost blinded, thus making me prone to die very easily.

    did i mention that i am on a Mac? ·_· (don't start useless flame wars please?) and well, i asked Steam support's help, but the methods they advised me did nothing. :-\

    SO, i came here asking for this: Is there some sort of console command that can disable/normalize these effects? o_o
    (i searched the web for those too, but found nothing ): so i thought that a modders forum could have the answers i need!)

    please, any help will be appreciated! here i include two screenshots of me jarated and underwater.
    and yeah! thanks in advance!
     
  2. Freyja

    aa Freyja ¯\_(ツ)_/¯

    Messages:
    2,880
    Positive Ratings:
    4,972
    Perhaps turn your graphics down. Maybe your card can't handle the speccy distorted effects and makes it black instead.
     
  3. alboon

    alboon L1: Registered

    Messages:
    16
    Positive Ratings:
    1
    whats the specs of ur mac, is it old new etc, upto date drivers. sounds very dodgy.

    i've just read your post in the steam forum, as one of the guys there said its to do with your mac update maybe steam know of a fix that may come out if enough people are getting the same error. or mac might make a fix? dont know see if there are any mac graphic patch that ati have made or something :S sorry i can't be more help.

    just a stab in the dark here have you tried running windows emulator an see if the error happens there?
     
  4. TaxiService

    TaxiService L1: Registered

    Messages:
    2
    Positive Ratings:
    0
    yay! feedback! well, my mac is kinda recent i guess, but not really new... anyway the drivers i got are the most updated i can get. :-\

    turning graphics down/updating everything was what steam told me to do too, but those did not help! >_<

    now, the funny thing is that this glitch did not happen when my machine ran the older OS! (i am on 10.6.4 now, but on 10.5.8 this did not happen!!) so it must be something about drivers! DX (anyway the older OS had other bugs such freezecam not showing up, and disappearing sounds happened more often etc., so downgrading to 10.5 is something i'd rather not do.)

    alboon: i have not tried emulating it with windows. o_O but i bet the glitch won't show up though. XD i will try to, if i can!


    BUT ANYWAY, since this is most surely a driver-problem, is there a way to fix these effects via modifying TF2? o_O 'cause drivers updates are not something i really can rely on...

    so, like, does anyone know some command that could... modify those effects? or disable them? because i tried everything else already! DX

    PS: btw this is the topic i started on steam, and this is the ticket of the question i forwarded to steam. (but you gotta have to be logged in to see the latter, i guess?)
     
  5. alboon

    alboon L1: Registered

    Messages:
    16
    Positive Ratings:
    1