A few problems with my map, that I havn't been able to figure out.

Discussion in 'Mapping Questions & Discussion' started by Wafip, Mar 19, 2010.

  1. Wafip

    Wafip L1: Registered

    Messages:
    11
    Positive Ratings:
    0
    Hello, This is the second map I have ever made. This first one(cp_canyon_feud) sucked and needs no further mentioning. The one I am working on now is much better, I hope. There are only a few problems left with my map, and any help you could provide me would be much appreciated.

    First of all my map is a payload-ctf map(don't worry I have all that working). Each team has a bomb that starts in their base. The teams must escort their bombs to the enemies base and blow a hole in it to gain access to the enemy's intel.

    Here are some screen shots:
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]



    The first problem I have is that half of the track(prop_static) I laid down on both sides shows up in game as errors, but only on other people's computers. I have check all of the properties I can think of between the track that I can see and the track that shows up as errors.

    Screen shot:
    [​IMG]


    Another problem is that people occasionally get stuck inside the bomb, or in front of the bomb, or in the ground around the bomb. The bomb is just one big stuck trap. I made the bomb from a tutorial I found here http://developer.valvesoftware.com/wiki/TF2/Creating_a_Payload_Map.

    Screen shots:
    [​IMG]
    [​IMG]


    Also, any suggestions for a better map name are welcome.

    Once again any help would be really appreciated. There might be some more problems I don't remember( I just picked this project up again, which is kinda sad with how close I am), if so I will post those later.
     
  2. lana

    aa lana Currently On: ?????

    Messages:
    3,077
    Positive Ratings:
    1,389
    The missing track is a custom model you have. You need to pack those into your BSP using Pakrat or MAN. I recommend Pakrat: http://developer.valvesoftware.com/wiki/Pakrat

    The second problem is that you need at least one team_train_watcher in your map and have the gamemode set to payload to use proper train collisions. Otherwise, bad stuff will happen.
     
    • Thanks Thanks x 1
  3. Wafip

    Wafip L1: Registered

    Messages:
    11
    Positive Ratings:
    0
    The models are not custom, and half of the prop_statics work fine.
    I looked into them having diff models but they do not.
    Edit: OK, I found out what the problem was. I had somehow made a copy of the track models, and I accidentally used those half way through.

    That worked, thank you very much.
     
    Last edited: Mar 20, 2010
  4. Wafip

    Wafip L1: Registered

    Messages:
    11
    Positive Ratings:
    0
    Oh, what would also be useful is if I could have the ctf hud and the train watch hud up at the same time. I am just assuming you can't do that.