A few compile errors

Discussion in 'Mapping Questions & Discussion' started by phatal, Jan 12, 2008.

  1. phatal

    phatal L6: Sharp Member

    Messages:
    259
    Positive Ratings:
    21
    I was able to clear up my PortalFlow problem. It appears it didn't like some cylinders.

    Now I have a few last errors to clear up that I think will be easy for you guys to solve.

    When I go in to tf2 to test out the full compile I get these errors in the console.

    Error! Variable "$detail" is multiply defined in material "concrete/wall024"!
    Error! Variable "$detailscale" is multiply defined in material "concrete/wall024"!
    SOLID_VPHYSICS static prop with no vphysics model! (models/props_hydro/cap_point_arrow.mdl)

    Then I try to buildcubemaps and get this.

    Current mod isn't in a subdirectory of "game"!

    *** Error: Skybox vtf files for sky_hydro_01 weren't compiled with the same size texture and/or same flags!
    Can't load skybox file sky_hydro_01 to build the default cubemap!

    I changed the map information skybox to sky_hydro_01_hdr and got this after the next compile trying to get the skybox cubemaps to work.

    *** Error: Skybox vtf files for sky_hydro_01 weren't compiled with the same size texture and/or same flags!
    Can't load skybox file sky_hydro_01 to build the default cubemap!



    Any thoughts or suggestions are welcome. TIA. :)
     
  2. Armadillo of Doom

    aa Armadillo of Doom Group Founder, Lover of Pie

    Messages:
    949
    Positive Ratings:
    614
    I know that you can ignore the skybox error. What prop type are you using for the cap_point_arrow? As for "Current mod isn't in a subdirectory of "game"!", your guess is as good as mine. Have you messed with the saved maps directories recently?
     
  3. phatal

    phatal L6: Sharp Member

    Messages:
    259
    Positive Ratings:
    21
    Saved maps directory? I'm not sure what you are referring to, but in an effort to correct the sdk update issue from 1/7 I did a full uninstall/reinstall for tf2 and sdk so all that should be current.

    I'll check the prop type to see what's going on with that. I know I have another of the same in the map that is identical that doesn't generate an error. Maybe I can just delete the old one and copy and paste the working one.

    I don't know why but I did a find & replace on my skybox to the same texture but changed the scale from .25 to 1 and that seemed to fix it. :confused1:
     
  4. phatal

    phatal L6: Sharp Member

    Messages:
    259
    Positive Ratings:
    21
    Ok. It compiled in hammer, but in game when building the cubemaps I got the same problems.

    This is what it shows in console.

    Code:
    Current mod isn't in a subdirectory of "game"!
    bounce: 1/1 sample: 1/34
    bounce: 1/1 sample: 2/34
    bounce: 1/1 sample: 3/34
    bounce: 1/1 sample: 4/34
    bounce: 1/1 sample: 5/34
    bounce: 1/1 sample: 6/34
    bounce: 1/1 sample: 7/34
    bounce: 1/1 sample: 8/34
    bounce: 1/1 sample: 9/34
    bounce: 1/1 sample: 10/34
    bounce: 1/1 sample: 11/34
    bounce: 1/1 sample: 12/34
    bounce: 1/1 sample: 13/34
    bounce: 1/1 sample: 14/34
    bounce: 1/1 sample: 15/34
    bounce: 1/1 sample: 16/34
    bounce: 1/1 sample: 17/34
    bounce: 1/1 sample: 18/34
    bounce: 1/1 sample: 19/34
    bounce: 1/1 sample: 20/34
    bounce: 1/1 sample: 21/34
    bounce: 1/1 sample: 22/34
    bounce: 1/1 sample: 23/34
    bounce: 1/1 sample: 24/34
    bounce: 1/1 sample: 25/34
    bounce: 1/1 sample: 26/34
    bounce: 1/1 sample: 27/34
    bounce: 1/1 sample: 28/34
    bounce: 1/1 sample: 29/34
    bounce: 1/1 sample: 30/34
    bounce: 1/1 sample: 31/34
    bounce: 1/1 sample: 32/34
    bounce: 1/1 sample: 33/34
    bounce: 1/1 sample: 34/34
    *** Error: Skybox vtf files for sky_hydro_01 weren't compiled with the same size texture and/or same flags!
    Can't load skybox file sky_hydro_01 to build the default cubemap!