A couple problems

Discussion in 'Mapping Questions & Discussion' started by $ausage, Jun 22, 2009.

  1. $ausage

    $ausage L1: Registered

    Messages:
    17
    Positive Ratings:
    0
    I am having a few problems with my map that is currently being worked on...

    a. I have a BLU spawnroom door with the func_respawnroomvisualizer. I tested it out, and the no entry symbol shows up for both teams. I have the visualizer's Associated Respawn Room property set to my BLU respawn.

    b. The back of my spawn door is completely black. The door has an interior on one side, and it leads to the outside.

    EDIT: I'm also having trouble with the cubemaps in my spawnroom, picture below.
     
    Last edited: Jun 23, 2009
  2. fubarFX

    aa fubarFX The "raw" in "nodraw"

    Messages:
    1,619
    Positive Ratings:
    1,709
    a. you need to use a filter_team entitie and type it's name in the "input filter" value of func_respawnroomvisualizer

    b. hu.. I dunno. any leaks? picture please?
     
  3. $ausage

    $ausage L1: Registered

    Messages:
    17
    Positive Ratings:
    0
    a. I'll try it pretty soon. EDIT: Still shows up for both teams.
    b. Recompiled it and checked the log...no leaks whatsoever. No ERRORS whatsoever.
    EDIT: Found these errors after compiling a third time:
    [​IMG]
    Inside BLU Spawnroom


    [​IMG]
    Outside BLU Spawnroom
     
    Last edited: Jun 22, 2009
  4. Open Blade

    Open Blade L7: Fancy Member

    Messages:
    439
    Positive Ratings:
    34
    Don't worry about the skybox error message. That's common and doesn't really mean anything. Try deleting your cubemap and place a new one there. Make sure you don't have a floating cubemap inside of a world brush.

    I'm not sure why that noentry texture has black. Never seen that before, ever. But you do need to resize it so the red circle is smaller and fits the brush.
     
  5. Pianodan

    Pianodan L3: Member

    Messages:
    108
    Positive Ratings:
    16
    I suspect your func_respawnroomvisulizer may be textured oddly. Make sure it's nodraw on all sides except the front, and use the face edit tool (not the overlay tool) to apply the no_entry texture to the front. While you're at it, if you use the "fit" option in the tool, that will correctly resize the graphic.

    As far as the logic goes, can you post your settings for the func_respawnroomvisualizer and the filter?
     
  6. $ausage

    $ausage L1: Registered

    Messages:
    17
    Positive Ratings:
    0
    @Open Blade: No cubemaps inside brushes, just one in the spawnroom, and a couple outside. Plus, I'm almost positive that it's the door that's black, because it still opens and the black moves up with the door.

    @Pianodan: I first made all sides nodraw, then selected only the front and made it the no entry sign, with the Texture Application Tool. And I never noticed the Fit button...I'm such a noob...here's my settings:

    VISUALIZER:
    FILTER:
    EDIT: I reran the map after inserting a new cubemap and fitting the no entry texture. The door is no longer black:

    [​IMG]

    ..but the cubemap still isn't working. I still have pink splotches on my walls.
     
    Last edited: Jun 23, 2009
  7. A Boojum Snark

    aa A Boojum Snark Toraipoddodezain Mazahabado

    Messages:
    4,769
    Positive Ratings:
    5,531
    No, you don't use the "input filter" setting for visualizers. All that should need to be done is linking it to a respawnroom of the proper team.
     
  8. $ausage

    $ausage L1: Registered

    Messages:
    17
    Positive Ratings:
    0
    I set the input filter to Allow All Inputs, and it still shows up for both teams. The associated respawn is the BLU respawn, for sure. I also tested the respawn room for the first time, to see if I could change classes without dying, and that works, thankfully.